Ticket #771 (closed defect: duplicate)

Opened 8 years ago

Last modified 7 years ago

Folder utterly deleted when selecting + pressing "enter"

Reported by: anonymous Owned by: anonymous
Priority: immediate Milestone: alternc-0.9.7
Component: Bureau: gestionnaire de fichiers Version: alternc-0.9.5
Severity: crash Keywords:
Cc:

Description (last modified by anarcat) (diff)

Hi,

This may be an expected behavior but it is rather dangerous. I just deleted a whole directory in my AlternC File browser... here is what I did.

  • I selected a folder in order to rename it
  • I typed the new folder name in the "move:" textfield
  • I pressed "enter"

The problem is that:

  1. by default, pressing enter activates the "delete" button
  2. the "delete" button does not ask for confirmation

I therefore did exactly the opposite to what I wanted (namely, move my original folder in order to backup it)!

Change History

comment:1 Changed 8 years ago by anarcat

  • Description modified (diff)
  • Severity changed from major to crash

yes, we need to change the order of the controls to change the default...

comment:2 Changed 7 years ago by nahuel

  • Milestone changed from 0.9.6 to 0.9.7

comment:3 Changed 7 years ago by benjamin

  • Status changed from new to closed
  • Resolution set to duplicate

#659 is the original (in french)

Note: See TracTickets for help on using tickets.